1

Is there a roadmap (or will there be in the near future) for official support for PHP 7 for Magento 1.x?

I know there is a community extension for making it compatible. And I know about the several PHP 7 topics here. But I am specifically wondering about official support, it would make the process a bit more convinient.

EDIT: I am looking for an official source or statement or maybe a post from the core team or something. In other words a source which is less opinion based.

2 Answers 2

1

The most official statement I got is from user KAndy (M2 core developer) in "Is Magento ready for PHP 7?"

Also, support of php 7 in Magento1 require backward incompatible changes and I think will be not supported officially.

1

Magento will be supporting Magento 1.x probably for the next couple of years. But most likely it'll be a security only form of support - officially it doesnt support 5.6 and PHP 5.5 is EOL now so I would not anticipate any official PHP7 support for Magento 1.x

The module you have mentioned I have used on a few projects with mostly a good success of doing so.

Some additional reading:

https://community.magento.com/t5/Version-Upgrades/What-is-the-end-of-life-date-for-Magento-1-9x-community-edition/td-p/36541

Future Support of Magento 1.9 - Coming Magento 2.0

1
  • Thanks for your answer. I am looking for an answer less opinion based. I edited my question. Are there any sources you can add?
    – Akif
    Aug 15, 2016 at 10:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.