0

This is my default_head_blocks.xml file code

<css src="css/source/_style-l.css" />   
    <css src="css/source/styles-m.css" />
    <css src="css/source/styles-l.css" media="screen and (min-width: 768px)"/>
    <css src="css/source/print.css" media="print" />
</head>

Is an application set to developer mode and all the CSS file incorrect location?

1
  • Are you inheriting from Blank or Luma? Aug 9, 2016 at 14:02

3 Answers 3

0

Use This: (Change the css path as required)

<action method="addCss" ifconfig="porto_settings/general/rtl" condition="0"><stylesheet>css/local.css</stylesheet></action>

1
  • kindly check your answer may be u have given answer for M1 not M2 check it once May 28, 2018 at 5:21
0

First you have to configure compilation of style in admin path given below

Store -> Configuration -> Advanced -> Developer -> Front-end development workflow

change to

Client side less compilation

Then edit your theme styles module wise and other web/css/source (common style)

app/design/frontend/vendor_name/theme_name
0

You need to refer below link.

http://devdocs.magento.com/guides/v2.1/config-guide/cli/config-cli-subcommands-static-view.html

also you need to run command for deploy, you can use anyone command

php bin/magento setup:static-content:deploy
or
php bin/magento dev:source-theme:deploy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.