1

I have noticed a strange issue recently on the Magento checkout. The same thing occurs whether I am using the default onpage Magento checkout, or if I am using the lotusbreath onepage checkout extension.

When I go to the checkout, there is a credit card form, in place of where you would usually have a list of payment methods (PayPal, Pay In Store, Sage Pay etc.). I can not see these other options now.

When I load the page, I do see them load, very briefly, but they are immediatley replaced by this form. I have disabled all payment methods, apart from pay in store, sag pay and paypal. Sage pay takes the user to their website to process payments, so the form does not belong to that.

Where could this come from?

  • I am unfortunately experiencing the same issue. Cropped up yesterday. Done full server scan and did not find any files infected related to this. It seems to be using Javascript payment.switchMethod('sagepaydirectpro') that shows the form but I am not certain. I've had to disable the site until I can find a resolve. Checked Design Config for scripts but couldn't find anything. Any help would be appreciated. – Chris Oliver Feb 6 at 20:42
2

This sounds like your site has been hacked. I'm sure this credit card form is displayed via JavaScript and sends entered credit card data to some unknown server far away, stealing your customers credit cards.

Take the site offline immediately and then start investigating the PHP code and other files, as well as configurations where scripts could have been added (often in System > Configuration > Design).

Then change passwords, make sure, that all security patches are applied and server software is up to date.

You will also have to notify your customers about this exploit, if people were trying to buy on your site while this form was in place.

See also: What should you do with the hacked installation?

0

I also had the same issue and now been solved by these simple steps. Just check or any miscellaneous scripts in head section. If found any encrypted script, then

Go to ->System-> Configuration-> Design ->HTML Head->Miscellaneous Scripts.

And delete all this script content.(Note take a backup of full site before performing deletion). Save all the changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.