I have 2 Store Views and 2 Websites in my Magento One of them is for the US and the other one is set to Canada. They are in the same installation and I am using a folder structure to display both websites www.mysite.com and www.mysite.com/ca/

Everything is working fine, but the Shipping Methods are not showing up in my Canada site.

It is very weird because some methods (Table Rates, Free Shipping) are working fine and I can see them on the Canada site, but Fedex and DHL show just on the US site.

I tried to use the inherited scope (Default) in System > Configuration > Shipping Methods and also tried to uncheck the "default" checkbox and have individual settings. Nothing seems to work

Any ideas of what could be the problem?


I checked in the DHL log and I can see that a request is made to their API and return success, but Magento is not showing it.

  • You might need to use separate credentials for each of your website Scope.
    – electroid
    Commented Aug 7, 2016 at 14:49
  • Unfortunately was not that. I got a new credential but still not working. Also, in the DHL log I can see that a request is made to their API with success, but Magento is not showing it =( Commented Aug 9, 2016 at 17:35
  • What about your site settings for the second website, do you change county origin in System -> Configuration -> Sales -> Shipping Settings for the website scope?
    – electroid
    Commented Aug 10, 2016 at 9:01
  • The origin is the same for both stores. However, I tried change that to test but no success with that... Commented Aug 10, 2016 at 15:47
  • Canadian site uses same products to sell? Products must have weight.
    – electroid
    Commented Aug 11, 2016 at 7:56

1 Answer 1


After many hours and a lot of tests, I discovered that the problem was something very simple: my base currency for the new store was Canadian Dollar but Fedex and DHL are quoting in US Dollar.

Now I need to figure out with their API how to receive a response in Canadian Dollar and everything should work fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.