0

I made a backup of the Magento website including the mysql. Now when I try to access the page I get a message saying "a:4:{i:0;s:95:"SQLSTATE[HY000] [1045] Access denied for user " 'minxny_dbadmi'@'localhost' (using password: YES)";i:1;s:2950:"#0 /home/minxny/public_html/lib/Zend/Db/Adapter/Pdo/Mysql.php(111): Zend_Db_Adapter_Pdo_Abstract->_connect()"

However I edited the local.xml file with the updated servers mysql info which has the database mysql username as minxny_dnadmi

and still for some reason its looking for the incorrect username. IDK where its getting the mysql username minxny_dbadmi when I have something totally different in the local.xml

  • check user permission – Minesh Patel Aug 6 '16 at 5:13
  • The issue is that the username minxny_dbadmi idk where it is getting that because I have a different database username in the local.xml file in app/etc folder. Is there anywhere else I need to edit the database connection info. I am not sure where its getting that username from. – Jayreis Aug 6 '16 at 12:45
1

If you are sure you have updated the xml with the correct details the issue must be with the database setup itself and user permissions.

Perhaps test to see if you can connect to the MySQL server via a standalone script (should be like 2 lines of code)

0

Make sure there is no backup file created in parallel to local.xml. And try to clear all cache types and cache storage.

  • OK so now I got the site sort of working in that I took the contents of app/etc/local.xml and copy and pasted that into a new file. I then deleted the local.xml and saved the new file as local.xml. No my issue is when I go to the site none of the images css seem to load. Also when I try to go to the admin also no images or css or even the submit button to login does not load and I have no idea why> The site is bit.ly/2aDbypp any suggestions to fix this? – Jayreis Aug 6 '16 at 23:06
  • Plus when I view my fromt page via brower and vire sorce I see (index):45 Uncaught ReferenceError: Mage is not defined(anonymous function) @ (index):45 (index):56 Uncaught ReferenceError: Translate is not defined(anonymous function) @ (index):56 (index):73 Uncaught ReferenceError: Varien is not defined – Jayreis Aug 7 '16 at 0:30
  • to check static content loading issue, open firebug and reload the page. Now check console or net panel for broken link and check whether url is correct or not. – Gulshan Maurya Aug 7 '16 at 8:27
  • if you are getting blank page then you have to check for error log in magento or check server error log. Also you can check by enabling display_errors in index.php . – Gulshan Maurya Aug 7 '16 at 17:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.