0

This is my first time posting here and I am hoping someone can help me out, I am a little stumped.

We have a Linux CentOS 7 server with PHP 7.0.9 and NGINX 1.11.3 installed.

We are trying to install Magento 2.0 but we keep getting a blank page when going to the setup.

We are not seeing an errors in the NGINX on PHP logs and the php info page renders correctly.

Please let me know what other information to provide.

Thank You.

  • check your http response code, is it 200 OK or 500 or 503 is there anything in browser console? – MagenX Aug 5 '16 at 20:02
  • @MagenX I don't see anything in the console. – Melissa Aug 5 '16 at 20:09
  • @MagenX I am getting a 200 response. There is a grey bar at the top of the page and that is all. – Melissa Aug 5 '16 at 20:09
  • @MagenX In the Net tab in FF, I see a few 404s (SITENAME/setup/index.php/navigation, etc). – Melissa Aug 5 '16 at 20:12
  • Magento 2.0 is dead, long live Magento 2.0... Unless you're past 2.0.5 or wherever the 9.8 earthquakes got patched. – Fiasco Labs Aug 6 '16 at 4:50
0

I face the same issue. I have 2 ways to resolve this problem:

  1. Installation via command line. Read more at http://devdocs.magento.com/guides/v2.1/install-gde/install/cli/install-cli-install.html

  2. Change config of PHP-FPM and Nginx.

Here are some possible solutions:

  1. In your php-fpm www.conf set security.limit_extensions to .php or .php5 or whatever suits your environment. For some users, completely removing all values or setting it to FALSE was the only way to get it working.

  2. In your nginx config file set fastcgi_pass to your socket address (e.g. unix:/var/run/php-fpm/php-fpm.sock;) instead of your server address and port.

  3. Check your SCRIPT_FILENAME fastcgi param and set it according to the location of your files.

  4. In your nginx config file include fastcgi_split_path_info ^(.+\.php)(/.+)$; in the location block where all the other fastcgi params are defined.

  5. In your php.ini set cgi.fix_pathinfo to 1

Read more at https://stackoverflow.com/questions/23390531/access-denied-403-for-php-files-with-nginx-php-fpm?answertab=active#tab-top

| improve this answer | |
  • 1,2,3 = no, 4,5 = maybe – MagenX Aug 8 '16 at 9:26
  • When I try to install via the command line I am getting the following error: SQLSTATE[HY000] [2002] No such file or directory. [InvalidArgumentException] Parameter validation failed. – Melissa Aug 10 '16 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.