0

I've set a Magento2 installation up with an SSL. I have this working fine in the backend of the website however all css/other calls in pub/static aren't being pulled through via HTTPS but HTTP.

I've tired to redeploy the static content but this doesn't seem to help.

0

What are your settings in Config->General->Web? What is "Secure Base URL for Static View Files"?

Chances are that your settings are requesting the files over http but your browser doesn't like the mix of secure and unsecure content.

Take a look in your browser console for error messages relating to this.

| improve this answer | |
  • The settings in Config->General->Web is correctly setup to use HTTPS. The browser console is that the CSS is being loaded using HTTP. I've updated the settings a few times to make sure it's correctly set to HTTPS but the pub/static is being pulled via HTTP. – lee murphy Aug 8 '16 at 9:42
  • Are the static files on a sub domain? Does this have a valid SSL certificate? – William Oakley Aug 9 '16 at 8:24
  • There no sub domain, and it does have a valid SSL certificate. It works fine in the admin side for https – lee murphy Aug 9 '16 at 12:13
0

Found that by completely disabling all caching on the server and site rather than clearing it Magento 2 correctly updated the Static file paths to HTTPS.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.