2

I have successfully run the compilation process, but when trying to enable the compilation mode, either through admin panel or through command line, I get no errors, but the state remains always disabled.

The folder includes has permissions 0775, and the file includes/config.php has 0777, so I don't think it's a permission issue.

Here is a typical sequence in putty:

myuser@serv01 [~]# php -cli public_html/shell/compiler.php disable
Content-type: text/html

Compiler include path disabled
myuser@serv01 [~]# php -cli public_html/shell/compiler.php enable
Content-type: text/html

Compiler include path enabled
myuser@serv01 [~]# php -cli public_html/shell/compiler.php state
Content-type: text/html

Compiler Status:          Disabled
Compilation State:        Compiled
Collected Files Count:    7605
Compiled Scopes Count:    4

UPDATE

Even changing the working directory didn't help:

myuser@serv01 [~]# cd public_html/shell
myuser@serv01 [~/public_html/shell]# php -cli compiler.php enable

etc...

UPDATE 2

The file includes/config.php is always empty, but the folder includes/src is updated / recreated during compilation.

3

You've lost your valid config.php file. The admin essentially comments out a line in that file to disable the use of the compiler (unless things have changed). Try pulling a clean includes/config.php from a clean Magento code base and then try enabling it again.

  • Thanks, I think you've got the point. As soon as I test it, I'll accept the answer or update the question! – perissf Jan 30 '14 at 7:42
0

Default contents of config.php file:

<?php
#define('COMPILER_INCLUDE_PATH', dirname   (__FILE__).DIRECTORY_SEPARATOR.'src');
#define('COMPILER_COLLECT_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'stat');

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.