3

In magento EE 1.13 setup when I am clearing the cache from admin it does not clear the cache and my changes are not reflecting in frontend.

When I clear the cache directories from server my changes starts reflecting.

Is there anything that admin cache clean functionality is not working.

9
  • check your /var folder permission on server..
    – Keyul Shah
    Jan 9 '14 at 15:36
  • var folder permission is 777 still not working :(
    – Nafee
    Jan 10 '14 at 7:00
  • not I have no clue how it is working ask your senior developer
    – Keyul Shah
    Jan 10 '14 at 7:28
  • I'm experiencing currently the same, but can not reproduce it. Probably a EE bug :(
    – Tobias
    Jan 11 '14 at 16:00
  • To reproduce the bug edit static pages or blocks but this is also infrequent.
    – Nafee
    Jan 13 '14 at 5:43
2

Since you indicate that you are indeed using the filesystem as the backend for your cache, I'm going to assume you need a patch from Magento. :)

There is a known-issue in EE 1.13.x which is listed amongst the known issues PDF available via our partner portal. The issue is SUPEE-1498 and described as "Admin Panel option System > Cache Management, Flush Magento Cache does not clear the full page cache directory." It was first reported in 1.13.0.0.

We don't really run into this issue because we always use Redis as the cache backend for the full page cache (and the normal cache). If you're up for it, setup Redis and use it for your cache backend, otherwise you'll need to reach out to Magento support for a patch.

1
  • I will second this.
    – philwinkle
    Mar 12 '14 at 22:19
1

If you have any sort of reverse proxy caching, you need to make sure that is cleared as well as your Magento cache.

If you have a server cluster setup, make sure that your cache is mounted to share across these clusters.

What does your local.xml look like? Do you have a <cache> node set in there? If so, the <backend> and <slow_backend> nodes could be overriding the default behaviors for your caching.

Try this: Turn off your caching entirely, (disable it in the backend). Do your changes show up now? If so, it could be a caching behavior problem set by these particular nodes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.