0

I am new to magento and i have just installed Magento locally on my mac. When i login into the Magento admin panel i get this error :

"One or more indexers are invalid. Make sure your Magento cron job is running."

After a bit of research i found that i need to run the following command from the root directory of my Magento installation.

bin/magento indexer:reindex   

However i keep getting this message after running the command "Magento supports PHP 5.6, 7.0.2, and 7.0.6 or later. Please read http://devdocs.magento.com/guides/v1.0/install-gde/system-requirements.html% "

My PHP version is 7.0.8 so i'm not sure why i am getting this error.

Thanks !

5
  • Try to run > php -v in your CLI and check version. It might be different from web one.
    – Max Pronko
    Commented Aug 2, 2016 at 20:25
  • Yep , you're right it shows PHP 5.5.27. How do i change it to the one MAMP uses?
    – JohnSnow
    Commented Aug 2, 2016 at 20:30
  • I am using github.com/phpbrew/phpbrew to update php version.
    – Max Pronko
    Commented Aug 2, 2016 at 20:32
  • Ugh, I had a hell of a time configuring Magento 2 dev site on MAMP Pro. I used AMPPS lamp stack and had better luck, although it ran awfully slow.
    – frshjb373
    Commented Aug 2, 2016 at 21:33
  • i managed to change the php version but now i am getting this : zsh: permission denied: bin/magento
    – JohnSnow
    Commented Aug 2, 2016 at 22:40

1 Answer 1

1

I fixed it with setting the right version of PHP and then "chmod u+x bin/magento" and then bin/magento indexer:reindex

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.