2

App mode is developer (checked also in env file).

Nginx has root www/.

www/index.php is hit.

Placed a die() statement in www/pub/index.php to make sure that the file isn't hit. It is not hit.

But if I look into page source, css and js are still served from pub folder.

In admin I have selected client side workflow.

So if I have some js in my module, I have to edit the js in pub/ and then copy my changes to app when done, which is quite a pain.

I don't know about any other settings that I can check.

grunt watch picks up less files but doesn't do anything to js files (I don't know if this is the intended behaviour).

Thanks!

1

The issue was that .htaccess and other files were missing from pub/static folder. After I added the whole pub folder from https://github.com/magento/magento2/tree/develop/pub and made sure the user and permissions are ok, the dev mode is now working as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.