1

I am building an extension, which I packaged under version 1.9, with the built-in packaging tool (Admin/System/Magento Connect/Package Extensions).

When trying to install the extension on Magento 1.7, I get a CONNECT ERROR: Unsupported resource type message in the console.

As I understand, this is because the unpack method changed after PHP 5.5, and the Magento code needs to be modified to install a package this way.

My question: is there a way to package an extension in a way that it is compatible with previous versions of Magento, without needing to modify core code?

All the solutions I found seem to be for the unpack method only, but I am looking for a way to make my extension compatible with 1.7-1.9.

| improve this question | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.