1

I am using a ModulesGarden theme Crystal and I can't get the banner slider to show in CMS homepage.

I've tried this:

<block type="core/template" name="home_banner" template="page/baners.phtml"/>

<block type="core/template" name="baners" template="page/baners.phtml" home_banner="1"/>

but it doesn't show still. I corrected the Permissions for Magento 1.9.2.4.

Any suggestions? I contacted the developers but they haven't gotten back to me.

3
  • Have You applied security patch ? Commented Jul 30, 2016 at 6:46
  • Please make sure the banner block is allowed in system >> permissions >> blocks Commented Jul 30, 2016 at 7:39
  • In which file you have coded? Commented Jul 30, 2016 at 13:12

2 Answers 2

0

Ok Lets Do Different Way. Create New Block like "Slider" and put the slider code in the "Slider Block".

After Creating Block Paste the following code in "header.phtml" (which is located at app\design\frontend\rwd\default\template\page\html\header.phtml).

<?php echo $this->getLayout()->createBlock('cms/block')->setBlockId('slider')->toHtml();?>
1
  • @gravvy : Tried My Answer? And if its Right than accept by clicking "Right" Sign and also upvote. Commented Jan 4, 2017 at 10:09
0

From the modulesgarden base tab, select plugins/slider

create 2 sliders name

crystal_slider_simple (this is the larger image) crystal_small_baners (used for the 2 smaller images)

also the instructions for enabling the theme are not correct,

template should be modulesgarden as advised, Skin, template, layout should be crystal

hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.