5

When I click the checkout I get the popup to register or sign in.
I have the configuration correct as a guest checkout.

I Enable Persistence is set NO. under Sales > Checkout > I have to Allow the guest checkout to YES. I am still getting the popup.

Am I missing something? However, when I refresh my checkout page and then click the checkout the 2nd time, I am redirected to the checkout page as a guest no popup.

Any suggestion?

1
  • Can you confirm you've flushed Magentos cache and static files have been flushed? Apr 7, 2019 at 11:06

4 Answers 4

0

Are you running Magento 2.0? If so, upgrade to 2.1. Here are directions: http://devdocs.magento.com/guides/v2.1/release-notes/tech_bull_21-upgrade.html

Here are the version 2.1 release notes: http://devdocs.magento.com/guides/v2.1/release-notes/ReleaseNotes2.1.0CE.html -One particular item to note:

Checkout

  • The Go to Checkout button now works as expected. Previously, when you clicked the Go to Checkout button, Magento would display a login pop-up window.
0

If you are still facing the issue then you can verify your options in core_cofig_data, in my case popup was keep appearing and when i did some r&d then i come to know then option was not reflecting the database values. You can enable it from this table manually and flush cache and check it again.

I knew it's not the actual method for the solution but it's making conflict with your js file that's why option is not reflecting the database values.

-Zahid

0

Funny, on my side I face the exact opposite issue. I disallow my checkout to guest. So they should see the popup. It's working on sandbox env...but on pre-production env instead of showing the modal / popup...it reload the cart.

0

For Eable guest checkout

  1. On the Admin sidebar, go to Stores > Settings > Configuration.

  2. On the left panel, expand Sales and choose Checkout.

  3. Expand Expansion selector the Checkout Options section. configuration of Checkout Options

  4. If the setting is for a specific store view, choose the store view where the configuration applies. When prompted, click OK to continue.

  5. Set Allow Guest Checkout to Yes.

  6. Click Save Config.

Then Cache flush and check on frontend side.

Note: if it's not working please check in database core_config_data table and check checkout/options/guest_checkout value is 1. database Changes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.