I have enabled SSL for only specific pages. From my wishlist page if I add any product to my cart I am getting error on console as:

Blocked loading mixed active content

There are lot of answers explains about including JS and CSS. Can some one assist me on this?

In my case wishlist page is having enabled SSL where as cart page is not. So, I am getting this error.

In the beginning I had add to wishlist URL without https that time also it thrown CORS error. So I added below,

Mage::getUrl('', array("_secure"=>true));

to create secure URL but now I am getting below error.

Blocked loading mixed active content

enter image description here

  • Are you adding product to cart by AJAX ? Commented Jul 28, 2016 at 6:35
  • @AnilSuthar yes I do
    – Anto S
    Commented Jul 28, 2016 at 6:37
  • Check your page url protocol (HTTP/HTTPS). All your AJAX calls must have the same protocol (HTTP/HTTPS) as your page url has. Commented Jul 28, 2016 at 6:47
  • @AnilSuthar I understood, since wishlist listing page is SSL enabled, I created add products to cart URL as https but this request cart action is not accepting. Review my updated question
    – Anto S
    Commented Jul 28, 2016 at 6:55
  • Try to remove http/https from AJAX url and replace it with just //. For ex, if AJAX url is http://yourhost.com/index/........., just use //yourhost.com/index/.......... This will auto detect protocols. Commented Jul 28, 2016 at 7:03

3 Answers 3


try replace http with https in the string of the url var.


Remove secure from the array("_secure=>true) than It will work fine


You will have this error in your site as long as the page does use a secure protocol whilst some content in it does not.

In short, you need to track what in your ssl page is called but yet does not use secure protocol.

--> go to your browser console and go to network tab, you will see all the calls made when your page loads and you may hover on the calls (on the column name) to see which link uses http protocol.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.