2

I am getting this error on an upgrade, even if I drop the table, it still happens. I have checked that the table is not there prior to upgrading.

Zend_Db_Statement_Exception Object
(
    [_previous:Zend_Exception:private] => 
    [message:protected] => SQLSTATE[42S01]: Base table or view already exists: 1050 Table 'catalog_product_entity_url_key' already exists
    [string:Exception:private] => 
    [code:protected] => 42
    [file:protected] => lib/Zend/Db/Statement/Pdo.php
    [line:protected] => 234
    [trace:Exception:private] => Array
1
  • This seems to be related to the environment as I got the upgrade to complete on a local machine (Not on production). I will post more info as I have it Jan 9, 2014 at 16:51

1 Answer 1

0

This was a stupid mistake: I forgot to put the prefix in the local.xml

5
  • Can you elaborate on what you mean by putting the prefix in local.xml. I'm encountering this same error and there isn't much else out there. Thank you. @brentwpeterson
    – thismethod
    Aug 16, 2016 at 22:53
  • @brentwpeterson What does this mean about prefix in local.xml?
    – Head
    Aug 29, 2016 at 23:52
  • @Supplement I did not put in the table name prefix in my Local.xml Aug 30, 2016 at 1:53
  • Do you mean this? <table_prefix><![CDATA[]]></table_prefix> .... i never put anything there and it usually functions correctly.. What did you have to put there? Can you give an example please. Thanks in advance.
    – Head
    Aug 30, 2016 at 16:44
  • Some people will use that. mage_ or magento_ Aug 30, 2016 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.