2

I don't know how and why I find the following in my robots.txt

Sitemap: http://www.[mySite].com/magento2/sitemap.xml

worse the link opens to a "404 page not found".

I have tried to remove it from my robots.txt (under Stores\General\General\Design) but just the next day and I can see it down at the end of my http://www.[mySite].com/sitemap.xml

Note that at the top of my http://www.[mySite].com/magento2/sitemap.xml there is a correct link to my sitemap.

How can I remove that permanently?

2

you have to set this option to Enable Submission to Robots.txt to NO

enter image description here

hope this will work for you

|improve this answer|||||
  • I don't want to disable the whole robots.txt !!! ... I just want to remove that extra automatically added sitemap link – Whaaaaat Jul 27 '16 at 6:30
  • it will disable robots.txt, it is just to stop append your sitemap.xml path to this file – liyakat Jul 27 '16 at 6:37
  • @Whaaaaat, don't forget to accept this answer, so some one can use it in future and it will help them – liyakat Jul 27 '16 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.