5

I can see all product images at the store level, but can NOT see any images in the admin area! Furthermore when I create a new product under admin, the "Browse Files..." and "Upload Files..." buttons are also missing.

I checked the var/log/system.log and see the following error each time i go to view the image tab:

2016-08-19T13:38:08+00:00 CRIT (2): Not valid template file:adminhtml/base/default/template/media/uploader.phtml

Could this be a file/folder permission issue?

Has anyone seen this issue?

Missing "Browse Files..." and "Upload Files..." buttons enter image description here

This is what I see!
It's missing "Browse Files...", "Upload Files..." buttons and none of the images are showing up. enter image description here

NOTE: New Discovery
Looking at the error log, I realized folder media/ and files media/editor.phtml and media/uploader.phtml do not exist! So I got them from the original Magento 1.9.1. and placed them under /app/design/adminhtml/default/default/template/.

The images showed up, But I am still missing the the "Browse Files..." and "Upload Files..." buttons.

Now I am trying to figure which files or folders are missing, to bring that functionality back.

Solved the disappearance of the buttons issue also.
While searching I found this link and found out that I am also missing another folder and it's content. skin/adminhtml/default/default/media/ which contained the 3 files flex.swf, uploader.swf and uploaderSingle.swf. Once I copied this folder the buttons appeared.

Also pursuant to the above mentioned article media folder should exist in the following folders:

skin/adminhtml/default/default
/app/design/adminhtml/default/default/template/system/config/system/storage
/js/tiny_mce/plugins/
design/adminhtml/default/default/template/

  • First try to check this in google chrome (because chrome has built-in support for flash). If every thing is working fine in chrome, then you need to update flash support for browser in which the problem is appearing. – Mohit Kumar Arora Jul 25 '16 at 5:06
  • I tried chrome. It produces the same results. – user2774042 Jul 26 '16 at 13:51
  • Any others suggestions? – user2774042 Aug 3 '16 at 15:33
5

Please check flash player is installed in your browser or not. If not then install flash player.

| improve this answer | |
  • Yes. It has Flash Version 22.0.0.209. Any other reason why this is not working? – user2774042 Aug 3 '16 at 15:34
5

This problem can be due to many reasons:

  • wrong permissions set to uploaded files Solution: Open lib/Varien/File/Uploader.php and make sure following permissions are set at chmod($destinationFile, 0666);. This code will be at around line 219.
  • At around line: 541, check whether following code exists:

    if (!(@is_dir($destinationFolder) || @mkdir($destinationFolder, 0777, true))) {

  • If still same issue persists, then rename .htaccess file to .htaccess.old in /media folder of magento.

Note: In both cases, you may need to flush cache before rechecking.

  • If still issue persists, then follow this tutorial:

http://www.blog.magepsycho.com/how-to-fix-the-issue-product-images-missing-in-backend-but-not-in-frontend/

Please let me know if you still find any problem.

| improve this answer | |
  • Sorry for the late reply I tired, changing line 219 from chmod($destinationFile, 0640); to chmod($destinationFile, 0666); and also changed line 541 from if (!(@is_dir($destinationFolder) || @mkdir($destinationFolder, 0750, true))) { to if (!(@is_dir($destinationFolder) || @mkdir($destinationFolder, 0777, true))) { with out any luck! I then renamed htacces. Still do no not get any images nor the add image link! I cleared cache after each step. What should the permissions to media, media/catalog, media/catalog/product folders and ultimately the image file be? – user2774042 Aug 8 '16 at 22:40
  • I followed blog.magepsycho.com/how-to-fix-the-issue-product-images-missing-in-backend-but-not-in-frontend/ also, with no luck. Any ideas what might be causing this? – user2774042 Aug 19 '16 at 13:10
4

Please read the question for more details. media folder should exist in the following folders:

/skin/adminhtml/default/default
/app/design/adminhtml/default/default/template/system/config/system/storage
/js/tiny_mce/plugins/
/app/design/adminhtml/default/default/template/    

In my case somehow all media folders were deleted!

| improve this answer | |
  • This is due to incorrect .gitignore. It has media/, and should /media – Volvox Jun 30 at 18:54
2

I believe that Chrome updated its settings for Flash. I went into my Flash settings in Chrome, then found the security settings. I added the 2 Magento domains that I work Admin in to the "allowed sites".

Doing this, I then refreshed the page and viola, the image editing showed up.

Seemed this was a Chrome issue as the Image uploader was working for me in INternet Explorer, just not Chrome.

| improve this answer | |
  • Yup, this just happened to me with chrome 69, but I never got a prompt from chrome asking me to allow flash on the backend. Thanks for sharing. – Turpachull Sep 26 '18 at 10:37
1

Just spent a very long time trying to find out what was going on here especially a I'm not a developer... Anyway my problem was due to a rewrite of:

app/design/adminhtml/default/default/template/catalog/product/helper/gallery.phtml

by another extension ( a permission one).

Anyway hope this helps someone.

| improve this answer | |
1

In my case the images doesnt work just in Chrome in Firefox the management of images is working fine, searching on the web i find this tutorial to enable Flash on Chrome https://helpx.adobe.com/br/flash-player/kb/enabling-flash-player-chrome.html after this is all working fine on Chrome, i wish this help somebody.

| improve this answer | |
0

You need to enable the flash player for your backend website.

Click on the locker in the navigation bar:

enter image description here

Select "Site settings" and there enable the Flash site support:

enter image description here

Refresh the page and you should be able to see the Image loader correctly.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.