5

I have created a transactional email in Admin, Marketing -> Email Templates.

Loaded in an email template from the Default Templates, but it's a custom module.

The template code loaded into the text area is:

{{template config_path="design/email/header_template"}}
            <!-- [ middle starts here] -->
            <table cellspacing="0" cellpadding="0" border="0" width="650">
                <tr>
                    <td valign="top">
                     content and vars -- all working fine
                    </td>
                </tr>
             </table>
{{template config_path="design/email/footer_template"}}

The actual template file is:

    {{template config_path="design/email/header_template"}}
            <!-- [ middle starts here] -->
            <table cellspacing="0" cellpadding="0" border="0" width="650">
                <tr>
                    <td valign="top">
                        <p><strong>Dear {{trans '%account_name' account_name=$customerName}}</strong>,<br/>
                        We have updated the point balance for you so that you can have relevant information of points earned or spent. To view more details, please click <a href="{{store url="rewardpoints"}}" style="color:#1E7EC8;">here</a>.</p>
                        <p style="border:1px solid #BEBCB7; padding:13px 18px; background:#F8F7F5; ">
                            <strong>The transaction detail</strong><br/>
                            <strong>Transaction title:</strong> {{var title}}<br/>
                            <strong>Transaction amount:</strong> {{var point_amount}}<br/>
                            <strong>Transaction status:</strong> {{var status}}<br/>
                            <strong>Current balance:</strong> {{var point_balance}}
                        <p>
                        <p>If you have any other questions, please feel free to contact us at <a href="mailto:{{config path='trans_email/ident_support/email'}}" style="color:#1E7EC8;">{{config path='trans_email/ident_support/email'}}</a> or call us at {{config path='general/store_information/phone'}} Monday - Friday, 8am - 5pm PST.</p>
                        <p>Thanks again,<br/>
                            <strong>{{trans '%STORE' STORE=$store.getFrontendName()}}</strong>
                        </p>
                    </td>
                </tr>

            </table>
    {{template config_path="design/email/footer_template"}}

And when I preview the template, the headers and footers show, however when the email is sent out, it's not showing the header or footer just the content.

  • Actually, turns out I didn't flush magento cache ;/ – Ajq Jul 22 '16 at 7:28
  • i flushed cache, but i continue to have this issue – LucScu Sep 13 '16 at 14:10
0

I was confused by this as well, as I had the same issue.

However - upon investigation, I found it was actually the email client I was using. Thunderbird. I cleared the cache within that, and emails loaded as expected.

  • I have the same issue, and it works with no client I tried. Other shop emails render header and footer just fine. – user3154108 Mar 6 '17 at 9:34
  • Any luck with this issue? I am getting the same. – Pallavi Sep 27 '17 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.