I followed the tutorial on this page


While I was able to get the source code provided to work without a problem, I have not been able to get the edited version of the code to work. It is telling me

Warning: include(Mage/VMR/Batch/Model/System/Config/Source/Dropdown/Values.php) [function.include]: failed to open stream: No such file or directory

Here is the XML Block defining that model

                    <multiple_dropdown translate="label comment">
                        <comment>Multiselect with global scope.</comment>

Any Ideas on why it is looking in Mage/VMR/.... Instead of VMR/.... ?

Edit: Here is my XML Block For Models

    <!-- VMR Batch Results Model Declaration -->
    <!-- VMR Batch Results Table Declaration -->
  • 1
    Do you have a models section in your config.xml which defines the VMR_Batch alias? It would be best to add your config.xml here. – Simon Mar 8 '13 at 23:05
  • Is VMR Batch module loaded? Is it listed in Advanced section? If it is, does that module config.xml have models section which describes where to look for its models? And finally if it has that section, does it have 'VMR_Batch' for model alias? – Petar Dzhambazov Mar 8 '13 at 23:06

Assuming the module is enabled and loading (if it's not, you'll need to solve that problem first), check the etc/config.xml in the VMR_Batch module and make sure it has the proper configuration declaring the class prefix for models:


Then where you are referencing the source model, reference it using all lower case to match the node name in the XML shown above:

  • Thank you for your response, I have edited my post and included my model definitions – Jeffrey L. Roberts Mar 9 '13 at 15:24
  • Unfortunately, we have created quite a few modules already under the prefix VMR, which requires use to reference VMR with all caps, otherwise the error will say Mage/Vmr/Batch ... – Jeffrey L. Roberts Mar 9 '13 at 16:36
  • To be clear, I'm not saying not to use VRM in all caps for your prefix. What I'm saying is the reference to the source model needs to be all lower case. You are declaring your model class prefix using the XML tag batch which means you need to reference the class as batch/system_config_source_dropdown_values. Magento will use this to create the final class name and file path with the uppercase VMR per the class prefix. – davidalger Mar 10 '13 at 3:32
  • The reason Magento is trying to load your class from Mage/VMR/Batch is because you do not have a class prefix defined for VMR_Batch in your config, only for batch. When there is no prefix defined it will always look in the Mage directory. – davidalger Mar 10 '13 at 3:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.