0

I´m creating a new store and I need to charge in 3 different currencies with different payment gateways, so I created 1 website, 3 store names and 3 store views (1 for each store name).

How do I make these 3 store names appear in a menu, same thing as change currency/ language menu type?

Thank you in advance!

0

1 Answer 1

0
Edit “page.xml” file.  
<block type="page/switch" name="store_switcher" as="store_switcher" template="page/switch/stores.phtml"/>

This line is located in the “page/html_footer” block. Cut the line and paste it just under the “page/html_header” block as shown below.

<block type="page/html_header" name="header" as="header">
<!--Added Store Switcher-->
<block type="page/switch" name="store_switcher" as="store_switcher" template="page/switch/stores.phtml"/>

Now add the below code in header.phtml file .
<?php echo $this->getChildHtml('store_switcher') ?>
4
  • Hi, I´ve done as you suggested and the switcher is not showing on my frontend. Here is my header code: <div class="header-button menu-list"> <a href="#"></a> <?php echo $this->getChildHtml('topLinks') ?> </div> <?php echo $this->getChildHtml('store_switcher') ?> </div> and here my page.xml : <block type="page/html_header" name="header" as="header"> <block type="page/switch" name="store_switcher" as="store_switcher" template="page/switch/stores.phtml"/> Did I forget anything? Commented Jul 19, 2016 at 17:42
  • please enable developer mode and enable the error reporting. also check the div structure using inspect element. and for debug just change the theme from your custom theme to base theme of magento. If it works in base theme then you have to check code in your custom theme files.
    – Jack
    Commented Jul 20, 2016 at 4:42
  • No error reported in var/log, when inspecting elements via chrome I got this as the only error: Uncaught TypeError: jQuery(...).jqTransform is not a function (here is the js file: terrasantaviagens.com.br/lojavirtual/skin/frontend/default/…), and yes when I changed the theme back to default it worked fine. So i belive it´s my theme, right? Where should I start looking for possible erros in it that is not allowing the code to work? Commented Jul 20, 2016 at 14:39
  • Oh, i forgot to tell you that language and currency switcher work perfectly in my theme. I´m having problem only with store switcher. :( Commented Jul 21, 2016 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.