2

I installed Fooman Speedster today (I've used it before without problems) and set it up as per the guidelines. I didn't experience any of the common issues however when loading the page I noticed all the JS was unavailable. I viewed the source to see a correctly generated minified link for the JS files, however on clicking it and attempting to view the result I get a 403.

As regards the CSS, this minifies and displays perfectly, and doesn't return a 403 when trying to view. I've been through the troubleshooting, checked permissions and there are no obvious faults, I just find it odd why the CSS works and the JS doesn't? Self tests passed without a problem and all relevant .htaccess files are in place.

Any suggestions?

  • your code include jquery? – Keyul Shah Jan 3 '14 at 17:14
1

Minify, the library that is used by Speedster, does not create 403 errors by itself. It currently looks like something in your server configuration does not allow the JS to be displayed (403) which seems very specific since as you mentioned the CSS works. Things to check here would be your htaccess files and server configuration.

One further thing to confirm is, with Speedster disabled, that none of the Javascript files included in your theme are missing when loaded individually.

  • I've not really checked out Speedster much, is it possible that minify is creating the file with the wrong permissions, i.e. not readable by the webserver. That would explain the error. – Peter O'Callaghan Jan 4 '14 at 17:37
  • 1
    if that was the case your combined css would have the same issue (and likely your resized product images as well). Normally the files that the server writes should be readable by the server. – Kristof at Fooman Jan 4 '14 at 22:51
1

Fooman is correct, what I did in the end was to break apart the generated URL and re-paste each .js file in 1 by 1 to re-form the URL. This allowed me to find the .js file that causes the problem which is a file called stickyfloat.js. The website I tried this on uses a dodgy theme and this stickyfloat.js is utilised somewhere within the site, however I tested the theory by removing this file inclusion via layout XML and re-minified and it worked correctly.

Thanks Fooman for the clarification. Although we haven't managed to locate an actual problem with stickyfloat.js, as it's not minified already and doesn't turn up anything major in jslint, I can confirm the problem isn't with Fooman's extension.

  • Glad to hear you found the culprit. Running the file through jslint.com should provide some pointers. A common one is that the JS relies on linebreaks instead of explicit semicolons. – Kristof at Fooman Jan 9 '14 at 5:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.