1

Why do I get this when I try to create a new User role in Magento2:

Exception #0 (Exception): Notice: Undefined index: title in C:\xampp\htdocs\magento2x_2\app\code\Magento\Integration\Helper\Data.php on line 24

  1. I have all the titles defined in my custom xml file.
  2. var/ cache, generation cleared.
  3. run setup upgrade.

Help required!

2

Go to your freshly created modules (some modules which you created last or before), open app/code/Name_Space/Module_Name/etc/acl.xml

put 'title tag' like this

<?xml version="1.0" ?>
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:Acl/etc/acl.xsd">
<acl>
    <resources>
        <resource id="Magento_Backend::admin">
            <resource id="Magento_Backend::stores">
                <resource id="Magento_Backend::stores_settings">
                    <resource id="Magento_Config::config">
                        <resource id="Namespace_Modulename::config_namespace_modulename" title="Put Here the Title"/>
                    </resource>
                </resource>
            </resource>
        </resource>
    </resources>
</acl>
</config>

This worked for me. Hope this would work for you also. All the best !

  • I'm getting the same issue but with a slightly different error message. If my error message is saying /vendor/magento/module-user/ then does that mean that there should be the acl.xml file located at the /vendor/magento/module-user/etc folder? – user3610374 Oct 23 '16 at 22:02
  • For me, i was in mid of creating a module with missing title in its acl, and this error was in order panel, however my module was not related to order anyways – Kumar A. Oct 24 '16 at 8:29
1

The issue is that one of your modules doesn't have a title defined in the acl.xml file. The easiest way to fix this is to update in src/vendor/magento/module-integration/Helper/Data.php to have:

$item['data'] = isset($resource['title']) ? $resource['title'] : '';

This will enable the UI to load but for one or many of the modules will have a blank space next to the folder. You then need to let the module developer know to fix the issue, but as a short term fix just add a title attribute to the acl.xml for the module yourself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.