1

I am unable to save/edit products or magento configuration. This is after setting my website to the following redirect for SEO purposes.

SEO redirect purposes (all done in magento admin)

  1. no index.php
  2. 301 redirect from http to https

The error message is below.

Mixed Content: The page at 'https:// example.com /index.php/admin/system_config/edit/section/web/key/a28ca18264dbb0bcdf848da4c2620ed4/' was loaded over a secure connection, but contains a form which targets an insecure endpoint 'http:// example.com /index.php/admin/system_config/save/section/web/key/ff882db370816b350dbf1b10cf065dac/'. This endpoint should be made available over a secure connection.

This is my current admin configuration.

  • Add Store Code to Urls: No
  • Auto-redirect to Base URL: No
  • Use Web Server Rewrites: Yes
  • Unsecure Base URL & Base Link URL: http://example.com/
  • Secure Base URL & Base Link URL: https://example.com/
  • Use Secure URLs in Frontend: No
  • Use Secure URLs in Admin: No

Can anyone help? I tried clearing cache but it does not work.

1

Change these two settings to 'Yes', clear cache and test.

Use Secure URLs in Frontend: No

Use Secure URLs in Admin: No

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.