0

enter image description here

As you can see from the image, recently a new ::before pseudoelement started appearing near my module link in the admin and I cannot find out where it is being pulled from.

Inspect element: enter image description here enter image description here

The module is quite large, so I'm inserting only the menu.xml. But please tell me where to look for possible causes. This wasn't appearing at the beginning, although if I checkout any of my previous commits it still appears. I don't load any css in my module. Cleared cache, recompiled:

<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:module:Magento_Backend:etc/menu.xsd">
    <menu>
        <add id="Vendor_Module::model"
             title="Module"
             module="Vendor_Module"
             sortOrder="9999"
             resource="Vendor_Module::model" 
             parent="Magento_Backend::content"
             action="module/model"
            />                            
    </menu>
</config>
2
  • Even though the title may imply it's not a duplicate the answer will explain in details how to find out how those content CSS properties are created Commented Jul 15, 2016 at 15:21
  • @RaphaelatDigitalPianism thanks Raphael. will take a look Commented Jul 15, 2016 at 17:31

1 Answer 1

0

I finally solved it by removing stores keyword from my id in menu.xml. It seems that whenever you add some words that are used by magento you will a certain class.

 <add id="Vendor_Module::stores"

became

 <add id="Vendor_Module"

Not the answer you're looking for? Browse other questions tagged or ask your own question.