This one is puzzling me - the review form is simply not showing on the review page

The reviews themselves are showing fine - but no form.

I have a theme set up but all the theme has is a local.xml, and that is not touching reviews at all - and neither is it changing or setting product.info.product_additional_data

From looking at things with my debug module, the block doesn't seem to be called at all

Things I have checked:

  • My theme does not change anything related to reviews, or even that "additional info" tab
  • I have no other theme installed
  • reviews are enabled
  • ratings are defined
  • guest can leave reviews
  • does your theme overrides catalog.xml OR review.xml? If so, can you show here ? Commented Jul 15, 2016 at 13:16
  • check in system > configuration > system > advance there is review module is enable or not Commented Jul 15, 2016 at 13:17
  • doesn't override catalog.xml or review.xml - it just has small tweaks in local.xml, nothing else
    – iphigenie
    Commented Jul 15, 2016 at 13:35
  • and yes, enabled
    – iphigenie
    Commented Jul 15, 2016 at 13:35

1 Answer 1


Just found the culprit - the ebizmarts mailchimp module - putting it here in case someone else gets that issue.

It comes with a whole bunch of extra modules which I had disabled (set to "false" in the appropriate /code/etc/modules xml files!) because mandrill is now quite expensive so these modules are useless.

But when I looked for places that touch product.info.product_additional_data the only thing I could find besides the standard Magento files was /app/design/frontend/base/default/layout/ebizmarts/autoresponder.xml

Now in my understanding there's no way a module which is disabled in /code/etc/modules should have its layout files processed, but when I commented out the review overrides in autoresponder.xml and cleared cache, the form appears

  • I've just been rebitten when updating magemonkey!
    – iphigenie
    Commented Aug 24, 2016 at 13:21
  • it is still happening on every module update
    – iphigenie
    Commented Nov 18, 2016 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.