1

Am not able to import image into my site, before am using localhost working good, after hosting not Working.

Magento version : 1.9.2.3

Note : After i import i got positive response in Admin, right after check into back end its not saved.

enter image description here

My image path :

enter image description here

11
  • I didn't understand...is this the product image? Were are you importing this in Magento? Jul 14, 2016 at 18:02
  • Yes, image importing not working
    – Gem
    Jul 15, 2016 at 4:12
  • You didn't answer my question. Where are you importing this? Could you post specifically? For example: I go to Catalog > Manage Products > Open a specific product, etc... Jul 15, 2016 at 20:16
  • @BrunoMonteiro : could you pls see this about what you asked.
    – Gem
    Jul 16, 2016 at 4:30
  • 1
    refer @ docs.magento.com/m1/ce/user_guide/store-operations/… , it seems you have added path like /5/2/52503855.jpg in import file and on server you have added images directly in media/import folder. Aug 8, 2016 at 7:23

3 Answers 3

2
+25

As Its all working fine on localhost then lets try

  1. check the host it have the gd extension installed?
  2. check hosting have all things required for magento using https://gist.github.com/atomicpages/4383809
  3. After this check permissions of magento dir var , media and app/etc

    find . -type f -exec chmod 644 {} \;

    find . -type d -exec chmod 755 {} \;

    chmod +x mage

  4. Also Disable cache and re-index database once

Then follow the other solutions as you already able to import correctly in localhost.

1

Basically media/import/ is where you will upload images to, then reference the filename and directories in your CSV file. examples:

  • 1) myproduct.jpg
  • 2) subdir/mysecondproduct.jpg

1) Uploading the above files & folders to the root of your Magento installation under media/import.

<Magento-root-directory>/media/import/myproduct.jpg

your CSV reference for the image would be simply: myproduct.jpg.

2) For the second example it after uploading to

<Magento-root-directory>/media/import/subdir/mysecondproduct.jpg

your CSV reference for the image would be: subdir/mysecondproduct.jpg

I've made a video awhile back which may help demystify the issues you are having:

Also Related:

Be sure that the webserver user / group it is running as.

Connect to your server via SSH, then see: top command or review your webservers configuration to determine which group is accessible, if not chmod -R 777 media/ in your Magento root directory may help as well.

1
  • not working what you suggested, am using magmi its working
    – Gem
    Aug 10, 2016 at 4:49
0

You have to change the permission of all images of media/import permission from 644 to 755 as images can not move with 644 permission. This will work only if it is working on your local system.

chmod -R 755 media/import/*

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.