1

After made that: How to change Magento timezone

My magento regional time was Europe/Paris but I tried to change to Europe/Budapest (both are the same..)

AOE Scheduler says

Last heartbeat is older than one hour. Please check your settings and your configuration!

What I have made:

Mage.php (before)

            date_default_timezone_set('UTC');

Mage.php (after)

            date_default_timezone_set('Europe/Budapest');

config.xml (before)

        <locale>
            <code>en_US</code>
            <timezone>America/Los_Angeles</timezone>
        </locale>

config.xml (after)

        <locale>
            <code>en_US</code>
            <timezone>Europe/Budapest</timezone>
        </locale>

I tried to

  1. Disable all schedules and remove programmed
  2. Disable cron job system
  3. Enable cron job system again
  4. Enable all schedules and re build programs.

But the problem keeps :/

Is like the cron job hour is advanced (real hour 11:36 in Spain): Cronjob time bad

Sugestions? Thanks!!

0

Problem solved

Do NOT change Mage.php file, only config.xml and cron jobs will work fine at time.

Disable all jobs and remove scheduled taks, enable again and all wil be synced.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.