I have installed Magento 2.1.0, I tried Install the Data Migration Tool , I tried Install the tool from GitHub by using

composer config repositories.data-migration-tool git https://github.com/magento/data-migration-tool
composer require magento/data-migration-tool:2.1.0

On running 2nd command, I am getting,

enter image description here what am I missing? I am using OS X Yosemite 10.10.5 , php 5.6.10 and MySQL 5.6.25

1 Answer 1


Seems like you did forget to setup the public and private key portions to use with the magento repository for composer to work.

Look here, they explain it well. http://devdocs.magento.com/guides/v2.1/install-gde/prereq/connect-auth.html

You need to authenticate as a member of magento marketplace.

  • have done this, will try again, Jul 28, 2016 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.