0

I had moved my magento site to a new domain after following the proper transfer domain steps i had successfully moved my site by applying the necessary steps the home page is appearing perfectly BUT the problem is i cannot access the inner pages i.e from the navigation http://thehubcollection.com/

When i try to access the inner pages i get the following error

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

1

This is a common issue in Magento. You can view that the url "http://thehubcollection.com/index.php/ethinic.html" is showing the result fine, it is due to insertion of index.php in the url.

To avoid this and make it work the other way, you will need to enable the mode_rewrite_url(Configuration>Web>Search Engine optimization), and if it is already yes, then

  1. Disable it(If it is fine for you to keep the site running with index.php, then ignore the other two steps)
  2. Get the mod_rewrite enabled from server side
  3. Enable the mod_rewrite from admin area, and clear cache.
  • well thanks for the sln but Could you pls throw some more light on your answer... i not getting how to enable mod_rewrite from admin panel – Dreams Design Jan 2 '14 at 9:58
  • After i disabled the search engine optimization Currently my URL shows like this : thehubcollection.com/index.php/ethinic/sherwanis.html BUT i dont want the index.php in between... – Dreams Design Jan 2 '14 at 10:06
  • Sure please follow below steps:: 1. Go to the admin. 2. From Main Navigation System->Configuration. 3. On the left hand side Under the General->Web 3. On the right side you will see the Search Engine Optimization 4. You can do YES/NO 5. If you did this Yes :: that means the index.php will remove from the url. But for this you have to enable the mod_write from server side as well. 6. If you did this NO:: that means the index.php will come on the url and your internal links of pages will work as you want. NOTE:: If you remove the index.php from url then just do the 5 steps – SoftProdigy Jan 2 '14 at 10:23
1

After many attempts and many revisions in the .htaccess file finally i was able to solve my issue thank god...
Hav to just set the RewriteBase / in .htaccess file
thanks for the help @SoftProdigy , @Marius @Bijal Bhavsar and @Cags

0

If you go to http://thehubcollection.com/index.php/casuals.html it works, this is a good indicator that your server isn't setup with mod_rewrite correctly (or the .htaccess file is missing completely, but I'd have expected a 404 in that case, rather than a 500).

  • But for that every time i had to use index.php in the url ?? – Dreams Design Jan 2 '14 at 8:45
  • mod_rewrite converts /casuals.html to /index.php/casuals.html so that Apache knows which file to call. You need to speak to your host about mod_rewrite. – Peter O'Callaghan Jan 2 '14 at 8:53
0
  • First check for .htaccess file, is it exists or not.
  • Second check is mod_rewrite is enabled in your server or not.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.