2

After upgrading from 2.0.7 to 2.1, none of my configurable products will save on edit. In the browser console I can see there is an ajax call to the Product/Validate controller that returns a 404 response (ex. admin/catalog/product/validate/id/269/type/configurable/store/0/set/4/?isAjax=true). This failure stops the save step from ever occurring.

Creating new configurable products works fine, editing simple products works fine (for example admin/catalog/product/validate/id/270/type/simple/store/0/set/4/?isAjax=true resolves correctly).

Accessing the validate URL directly in the address bar also works (at least to resolve to a 200 response).

I've tried deleting and completely re-installing the vendor directory via composer, after clearing the composer cache so new files were pulled.

Tried recompiling, all the usual cache clearing, re-indexing.

Does anyone have any ideas on what to try to possibly resolve this? I'm baffled.

------- Update -----------

The OS distro that I am running this on is CentOS 6.7. Interestingly, I have a Windows 10 development installation on XAMPP that I upgraded to 2.1 and all seems to work there. I also tried a clean install of 2.1 in a new directory on CentOS, but that also failed in the exact same way.

I find it interesting that a GET request (pasted into browser address bar) returns a 200 response, but a POST request does not. To me that signals some sort of failure at the routing level to recognize the URL pattern via POST, but I'm not quite sure how to track it down. Is it related to this particular Linux distro? No idea yet.

  • I am experiencing the same issue of being unable to save configurable product edits after updating to 2.1 through the "Web Setup Wizard". – M_User Jul 19 '16 at 22:52
  • I wish I had an answer for you. What OS are you running on? This issue is NOT happening on a development install on a Windows 10 XAMPP setup, only on my production install, which is running CentOS 6.7. Do you know which distro you are using? Maybe there is a clue there. I'm going to ask my hosting company if they have any idea. – Michael A Jul 20 '16 at 5:28
4

My host is Nexcess, this issue was resolved by them when I opened a ticket about the issue . They updated the apache mod_security that was apparently blocking the POST action to the URL. Problem solved.

  • Same issue here. Fresh install of Magento 2.1.6. on Nexcess SIP-200. They took care of the issue in a few minutes. – Daniel Kratohvil May 15 '17 at 15:48
0

My host (Nexcess) is also running CentOS 6.7 (final). I upgraded from 2.0.2 to 2.1.0. I am also having an issue with the component manager taking 10 minutes to load, and making my entire backend inaccessible during this time. I think PHP is hanging on the session data. By any chance is this affecting you also?

My host says my composer.json file indicates I am still on version 2.0.2, but the Magento admin pages say I am on 2.1.0.

My host recommended I roll back to 2.0.2 and try the upgrade again, but I am considering a fresh installation of 2.1.0 to rule out everything except a server issue or Magento bug.

  • I'm on Nexcess too, they did an update to the Apache mod_security and it resolved this issue for me. I would ask them to look into that. – Michael A Jul 21 '16 at 14:52
  • As for the composer, you could manually update the json file to "magento/product-community-edition": "2.1.0", or run the command line composer require magento/product-community-edition '2.0.*' --no-update and then composer update, then run the magento upgrade: php bin/magento setup:upgrade. – Michael A Jul 21 '16 at 15:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.