0

I am trying to create a staging site to debug our site. I have created it: - Disabled compilation. - Disabled caching directly in the db - Deleted the var/cahce/ contents just to be sure. - Updated unsecure_base_url and secure_base_url in the db.

I've also checked the base skin urls etc just to make sure they are correct.

I've disabled ssl in the db to keep things simple.

Changed the database credentials in local.xml

Changed the apc prefix to be specific to the staging site.

Disabled the BOLT full page cache we use.

Checked the virtual host setup to make sure it is loading from the right directories.

Yet when I access debug.domain.com two issues happen. In the frontend the catalog links etc all refer to www.domain.com not debug.domain.com and when I access the admin and log in none of it renders correctly because all of the resources have the full file path amended so it tries to load e.g.
http://debug.domain.com/var/www/vhosts/debug.domain.com/web/content/skin/adminhtml/default/default/lib/prototype/windows/themes/magento.css

rather than http://debug.domain.com/skin/adminhtml/default/default/lib/prototype/windows/themes/magento.css

I'm totally stumped, I've been through loads of walkthroughs trying to spot something I've missed, can anyone spot anything I've forgotten or suggest anywhere else to look?

| improve this question | | | | |
1

The issue you are seeing can happen when you have css/js merging turned on but Magento doesn't have the required permissions to write to the media directory.

As a quick fix you can turn off css merging, alternatively try changing the media directory permissions to allow Magento write permissions. The permissions required will depend on your server, Magento recommends 700 in there docs, however if that doesn't work you could try something a bit more forgiving like 755.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.