4

I am export my products after hosting its not working, but from my localhost its working fine. I can not export from import/export,

am increased max_exe_time

my store consist 30,000 products

When i try to export products, am faced 500 internal error

enter image description here

1

Probably the export execution hit the max_execution_time or memory_limit limits set by php. However, if your application uses Apache as a webserver, you should be able to modify these limits by setting them in your .htaccess.

#Increase the memory limito to 1G
php_value memory_limit 1G

# Define the script timeout after 1 hour
php_value max_execution_time 3600

# If Magento fails after submitting a form you may need to tune the input limits

php_value post_max_size 5M
php_value upload_max_filesize 5M
php_value max_input_time 300

After editing the .htaccess, upload it in the Magento root.

Warning:

errors in the .htaccess file may lead to unreachable (error 500) website. Test it locally before uploading it.

| improve this answer | |
  • not working.... – Gem Aug 29 '16 at 8:20
  • So, you have to look in your Hosting panel for the error_log report and check if something is reported in there – Enzo Perrotta Aug 29 '16 at 8:52
1

According to the code, there's two possible reasons behind the No valid data sent error:

public function exportAction()
{
    if ($this->getRequest()->getPost(Mage_ImportExport_Model_Export::FILTER_ELEMENT_GROUP)) {
        try {
            /** @var $model Mage_ImportExport_Model_Export */
            $model = Mage::getModel('importexport/export');
            $model->setData($this->getRequest()->getParams());

            return $this->_prepareDownloadResponse(
                $model->getFileName(),
                $model->export(),
                $model->getContentType()
            );
        } catch (Mage_Core_Exception $e) {
            $this->_getSession()->addError($e->getMessage());
        } catch (Exception $e) {
            Mage::logException($e);
            $this->_getSession()->addError($this->__('No valid data sent'));
        }
    } else {
        $this->_getSession()->addError($this->__('No valid data sent'));
    }
    return $this->_redirect('*/*/index');
}

Reason 1: An exception has been thrown

This corresponds to this bit of code:

            Mage::logException($e);
            $this->_getSession()->addError($this->__('No valid data sent'));

So you're getting this default message but that does not tell you what happened.

Fortunately the Mage::logException line automatically logs the exception into the exception file which is var/log/exception.log by default.

So I suggest you find out what the exception is by checking this file and edit your question with the exception that will help us fixing your issue.

Reason 2: The request does not contain the export_filter data

In case you don't have anything in your var/log/exception.log file that means that no exception is being thrown and thus this is the following condition that is not matched:

if ($this->getRequest()->getPost(Mage_ImportExport_Model_Export::FILTER_ELEMENT_GROUP))

My suggestion in this case is to check the content of the request by adding:

Mage::log($this->getRequest()->getPost());

Right before the condition and then check in var/log/system.log to see what the request contains.

If you get the error that means the request does not contain an entry called export_filter

The main reason I can think of is that maybe the PHP maximum POST size is reached and thus you need to increase the PHP variables mentionned by Fabian:

post_max_size=1024M

I highly doubt you have to deal with upload_max_filesize as you're doing an export here and not an import.

| improve this answer | |
  • 1
    I get same error. – Gem Aug 31 '16 at 11:14
  • @JeevaRathinam well what did you do ? Did you follow my guide for reason 1 ? – Raphael at Digital Pianism Aug 31 '16 at 11:15
  • yes, am increased post_max_size, upload_max_filesize – Gem Aug 31 '16 at 11:32
  • @JeevaRathinam please read my answer and follow the steps in reason 1. What do you get in var/log/exception.log – Raphael at Digital Pianism Aug 31 '16 at 11:37
  • 1
    @JeevaRathinam well that's not the point. Please answer my question and tell what's in var/log/exception – Raphael at Digital Pianism Aug 31 '16 at 11:43
0

I have a same issue. I disable DeveloperMode in Magento 1 by using:

Mage::setIsDeveloperMode(false);

in file index.php

| improve this answer | |
  • 1
    Not working, i get same error – Gem Jul 9 '16 at 7:52
0

Normally this means, that the uploaded file is not there.

There are two settings which need to be increased:

; Maximum allowed size for uploaded files.
upload_max_filesize = 40M

; Must be greater than or equal to upload_max_filesize
post_max_size = 40M

Make sure, both settings are greater than your file size.

If you get a response from the server it is NOT max_execution_time, if php kills his process due to the execution time, you get a white page, a apache/nginx 500 or whatever. No magento page.

| improve this answer | |
  • not working.... – Gem Aug 29 '16 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.