4

I'm having issues with change to store view,

I have this site: https://example.com/ working OK

but when i try to change the language (so, the store view),

http://example.com/?___store=english&___from_store=spanish

I just see the Error 500, and the site stop working until clear the cookies of the browser.

I don't know, because i have the same code in another server, and the code works fine.

This error happens only in the page with some products data.

Any ideas?

  • 1
    Check logs in server and post their content with question. – Prateek Jul 8 '16 at 8:14
  • Apache logs says: Got error 'PHP message: PHP Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried to allocate 512 bytes) in /opt/bitnami/apps/magento/htdocs/lib/Zend/Db/Statement/Pdo.php on line 291\n' – rleiva Jul 8 '16 at 12:51
  • It's weird, because I have 8GB as memory_limit, but the error comes with just 1GB – rleiva Jul 8 '16 at 13:26
2

This is a server error. if you have a developer store, please go to index.php under your root magento store and enable developer mode. Just paste this code after line 72 Mage::setIsDeveloperMode(true); and uncomment ini_set('display_errors', 1); if it is commented. Then you are able to view the error and can research for it on google or can comment here.

| improve this answer | |
  • Apache logs says: Got error 'PHP message: PHP Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried to allocate 512 bytes) in /opt/bitnami/apps/magento/htdocs/lib/Zend/Db/Statement/Pdo.php on line 291\n' – rleiva Jul 9 '16 at 21:59
  • But in my php info, i have 6000M of memory_limit, but still going down on 1073741824 bytes (1GB), so i don't understand, this happens only on 1 storeview – rleiva Jul 9 '16 at 22:01
  • And the server have 15GB of memory – rleiva Jul 9 '16 at 22:03
  • Can you send what magento shows after enablung deceloper mode in the way I told you please? – Ledian Hymetllari Jul 9 '16 at 22:43
  • Sure: Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried to allocate 87 bytes) in /opt/bitnami/apps/magento/htdocs/lib/Zend/Db/Statement/Pdo.php on line 291 – rleiva Jul 9 '16 at 22:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.