0

I am getting empty array in post in admin form.

$this->getRequest()->getPost()

It was working fine before I have updated 3 more fields to this form field like below:

$fieldset->addField("meta_title", "text", array(
                        "label" => Mage::helper("modulename")->__("Meta Title"),
                        "name" => "meta_title",
                        ));

                        $fieldset->addField("meta_description", "textarea", array(
                        "label" => Mage::helper("modulename")->__("Meta Description"),
                        "name" => "meta_description",
                        ));

                        $fieldset->addField("meta_keyword", "text", array(
                        "label" => Mage::helper("modulename")->__("Meta Keyword"),
                        "name" => "meta_keyword",
                        ));
2
  • Have you tried Mage::app()->getRequest()?
    – mbalparda
    Jul 7, 2016 at 17:34
  • Yes i have tried it but not working Jul 7, 2016 at 17:38

1 Answer 1

1

I got blank array in post due to some misconfiguration of .htaccess rule

I have changed my .htaccess with fresh one it solved my problem

may be it will helpful to someone.

1
  • Can you please let me know what change the htaccess file have ? Oct 24, 2017 at 5:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.