2

I just tried to run Magento-CE-2.1.0. I use Ubuntu 16.04 and the php version is 7.0.4-7ubuntu2. But I got this error when I wanted to run Magento:

'Magento supports PHP 5.6, 7.0.2, and 7.0.6 or later. Please read Magento System Requirements.'

What should I do? Can't I run Magento on ubuntu 16?

6

Nope, they have a big issue with PHP version on Ubuntu 16.04 .

Your only real option is to change PHP version to 7.0.6 or 7.0.8 or wait for next release (they are going to fix it).

Look here for more information: https://github.com/magento/magento2/issues/5131 .

Look here for PHP upgrade: https://launchpad.net/~ondrej/+archive/ubuntu/php?field.series_filter=xenial

UPDATE:

Ubuntu 16.04 has been updated to support 7.0.8, so Magento 2 is no more an issue on Ubuntu 16.04.

4

The problem is that Magento 2.1 does not support PHP from 7.0.3 to 7.0.5. More information here: Why doesn't Magento 2.1 support PHP 7.0.3 to 7.0.5?

As you're running 7.0.4 you need to upgrade to at least 7.0.6 to be able to run Magento 2.1 on Ubuntu 16.

0

Using ubuntu should not make any difference. Try running php version 7.0.4 if you can rather than 7.0.4-7 or try php 7.0.6

More information on upgrading php on ubuntu: https://askubuntu.com/a/565961

0

To clarify, I believe the issue is with composer.json. You might be able to add 7.0.4 in composer.json and get it to work. We've done a lot of testing and found that 7.0.4 does work; however, 7.0.5 does not work due to a known issue in that release.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.