0

I don't know why my CMS page content keep automatically redirect to homepage.

Example: I click on link below:

http://magento.lifegood.com.my/customer-service

then my magento site will bring me to homepage.

I totally have no idea to fix this bug after I hard trying one day on it.

Update: Here is my .htaccess

6
Open your admin panel of magento.

Goto

System>Configuration>>Web> URL Option

and change

Auto-redirect to Base URL to No.
  • Thank you assist, I had changed my setting but still get the same result :( – Yap Wei Mun Jul 6 '16 at 6:57
0

As I see - all your cms pages redirects to home page. This can mean that CMS Magento module is broken or disabled.

1) Check "Admin - System - Configuration - Advanced" and find Mage_Cms line there. Check if it's not disabled.

2) Go to "Admin - System - Configuration - Developer" and enable Logging Then click on Cms page link on frontend And then check var/log/ folder of your Magento instance. Some info can appear there

0

One another thing that you need to remember is if you're site is accessed on https like

https://www.yourdomain.com/

You should also make sure that the base Link URL should be on https too. Otherwise Magento .htaccess rules will redirect you back to the Base Url

So the bottom line is URL Base Link under system - configuration - web - HTTP should be https://www.yourdomain.com/

After this clean / refresh your cache and reload your pages, This time magento wont reidrect you to home page.

web/unsecure/base_link_url

If you dont want to do this, then you need to change the .htaccess rules as shown in this SO thread https://stackoverflow.com/a/25528651/777103

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.