2

I am testing my plugin on Magento version 1.9.2.4. Installation on Magento Connect Manager seems to be ok but when I try to find it in configuration tab in Admin Panel - it's not there (it works on earlier versions for example 1.9), so I went to directories where it should be installed and I found something strange... Magento changed every php file from my plugin package to empty directories, for example:

app/code/community/SalesManago/Tracking/Block/Layer.php

It's now a folder with "Layer.php" name and it's empty.

I need to copy everything manually to install it correctly... Does anyone had this problem before?

5
  • This is not a problem of Magento. This is problem of operating system which is not understanding type of element which is being copied. Jul 5, 2016 at 8:36
  • I am testing it on localhost (Ubuntu 14.04), on v1.9 everything its ok but on 1.9.2.4 it fails - the same host.
    – P. Grzanka
    Jul 5, 2016 at 8:56
  • Edit: Now on the v1.9 I have the same problem. Do you know how can I fix it ?
    – P. Grzanka
    Jul 5, 2016 at 10:44
  • It may be due to incorrect folder permissions or some infection by malware. But I can't say exactly. If you find it's solution, please let me know also. Jul 5, 2016 at 11:33
  • Ok, thx for replay.
    – P. Grzanka
    Jul 6, 2016 at 10:39

1 Answer 1

0

I found a solution for my problem. It was extension package format, when I try to install my plugin with *.tar.gz format it fails like I describe above, but when I change it to *.tgz it work correctly! Maybe someone has the same problem, so this is an answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.