SO today the search index started reindexing forever just says processing. followed all kinds of tutorials online about this nothing is working meanwhile the search for goes to http 500 ugh......

so after the admin panel just sits there and displays processing on reindex I tried to reindex via putty and heres the error i get

root@ip-192-**** [/home/account/public_html/shell]# php indexer.php --reindex catalogsearch_fulltext

and i get

Fatal error: Class 'Mage_Mstcore_Helper_Debug' not found in /home/account/public_html/app/Mage.php on line 547

all other indexes properly

I set them to manual and rebooted the server but its still stuck on processing ?? how do i kill that process. so i can trouble shoot further

what sql table is this the full text right? mage_catalogsearch_fulltext

Can I safely just empty that table ? i seen someone say something about that I havent tried it yet.

whenever a user searches for something they get a http500 timeout this sucks :(

1 Answer 1


You should first disable MstCore (Mirasvit_MstCore) extension from app/etc/modules/ and try reindex. If it still just hangs, try to reindex by CLI (shell) commands, listed here Re-index magento via ssh / putty

If you want to clear fulltext (catalogsearch) data, you should truncate catalogsearch_fulltext, catalogsearch_query and catalogsearch_result. You will get Foreign Constraint... Error while truncating table catalogsearch_query, you can manuall select all rows and can delete.

  • thanks that worked well with the exstension off need to turn it back on , the core one was already off so i turned them all off the mirasvit one one by one search autocomplete mispell etc. , how did you know i was using that extension? is this a known problem with that extension should i uninstall it and use something else? Jul 1, 2016 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.