7

I have a few Magento (CE 1.7.0.2) sites on a VPS server that currently runs MySQL 5.0.9 and PHP 5.3.26

The datacenter company that hosts the VPS wants to upgrade the MySQL and PHP version due to the new requirements of WHM/Cpanel

Will there be any problem if they upgrade to these mysql / php versions?

  • did anyone read the question? they are asking about MySQL 5.5, which is an upgrade option in WHM not PHP versions. I am experiencing the same issue and have not upgraded PHP at all..just MySQL – user5737 Mar 18 '14 at 1:58
  • Note: Since then, install the PHP 5.4 patch magentocommerce.com/download released Jan 17, 2014 – Fiasco Labs Oct 27 '15 at 15:29
7

Of course you can.....

The docs do say that Magento doesn't support newer PHP...

The only issue you'll find that is easily solved happens with a change in the PHP interpreter dealing with Abstract class inheritance enforcement.

There are two files in the Zend library that generate PDFs & Images that need an extra function and parameter added and then its pretty shored up.

Just keep an eye on your logs, the files will jump out when you try to print a shipping label, or invoice.

I've had no problem running Magento on PHP 5.5 with this one consideration. 5.4 - 5.5 has minimal incompatibilities, none of which are found in Magento or associated libraries.

I have two Mage Builds running on my personal server on exactly 5.5 and 5.3.28, works great. One is 1.7.0.2 and one is 1.8

  • Actually php version is not my priority concern. Did you guys actually dun Magento on MySQL 5.5? If there will be a problem with MySQL 5.5, then I will have to tell the datacenter to upgrade to MySQL 5.1 – user4485 Dec 27 '13 at 7:35
  • Normally, 5.5 is not only no problem, but encouraged before 5.1 by means of performance; so, if you don't do some nasty SQL magic in one of your custom modules, 5.5 will be fine ;) – simonthesorcerer Dec 27 '13 at 9:40
  • Did you try magento 1.7.0.2 on MySQL 5.5 without custom modules? – user4485 Dec 27 '13 at 14:04
  • Yes... works fine. – mprototype Dec 27 '13 at 18:24
  • 1
    note: Magento released a PHP 5.4 patch – mprototype Feb 6 '14 at 6:12
4

You can find Magento's system requirements here: http://www.magentocommerce.com/system-requirements

Officially they say Magento is compatible up to PHP 5.3.24; but I have never had problems with newer versions. There will only be a problem when it comes to PHP 5.4, when you have to take care of small issue within the Zend Framework.

1

Magento 1.7 is fully compatible with MySQL 5.5, but if you install it on MySQL 5.6, there is an incompatibility in the installer and you will see this error

Database server does not support the InnoDB storage engine.

You'll have to patch app/code/core/Mage/Install/Model/Installer/Db/Mysql4.php, as explained in this StackOverflow question:

https://stackoverflow.com/questions/15443448/magento-install-complains-about-missing-innodb-when-it-is-available

Replace:

public function supportEngine()
    {
        $variables  = $this->_getConnection()
            ->fetchPairs('SHOW VARIABLES');
        return (!isset($variables['have_innodb']) || $variables['have_innodb'] != 'YES') ? false : true;
    }

with this:

public function supportEngine()
    {
        $variables  = $this->_getConnection()
            ->fetchPairs('SHOW ENGINES');
        return (isset($variables['InnoDB']) && $variables['InnoDB'] != 'NO');
    }

This is one of the rare cases where a core hack is justifiable since with the next Magento update the patch will be redundant anyway

0

Magento doesn't support PHP 5.4 per it's system requirements doc. That said, Community Edition doesn't appear to have any trouble working in a PHP 5.4 environment. Enterprise Edition would be a different story though…where certain admin sections disappear due to some SimpleXml differences.

Since you're running CE 1.7, the biggest risk here is likely going to be in customizations, modules, your theme, etc. There is no way to know for sure that it will work under PHP 5.4 without testing it in a staging environment.

My opinion: Don't upgrade your stack yet. Test your site thoroughly on a VPS with the new versions, then maybe allow the upgrade to take place. Upgrading without testing first is asking for disaster. If the upgrade causes problems, odds are you're going to have to immediately switch hosting providers since the likelihood of them rolling back to PHP 5.3.x is most likely nonexistent.

  • 1
    You might want to edit that since the 5.4 patch was released. – mprototype Feb 6 '14 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.