3

Is there a status for https://repo.magento.com/ to check if everything is working fine and decide if it is a local issue or not?

It seems that this morning the repo is not responding and information is loaded from cache with no 2.1:

The "https://repo.magento.com/packages.json" file could not be downloaded: Failed to enable crypto
failed to open stream: operation failed
https://repo.magento.com could not be fully loaded, package information was loaded from the local cache and may be out of date
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package magento/product-community-edition 2.1.0 exists as magento/product-community-edition[2.0.4, 0.42.0-beta7, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.5, 2.0.6, 2.0.7, 2.1.0-rc1] but these are rejected by your constraint.
1

I do not know of any offical page.

Not great but I guess you can check access to: https://repo.magento.com/packages.json

http://www.isitdownrightnow.com/repo.magento.com.html

| improve this answer | |
1

composer diagnose is a better option.

Foound out what the issue was:

The OpenSSL library (0.9.8y) used by PHP does not support TLSv1.2 or TLSv1.1.
If possible you should upgrade OpenSSL to version 1.0.1 or above.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.