0

I am getting the following error when trying to install the data migration tool

composer require magento/data-migration-tool:2.1

  Problem 1
- The requested package magento/data-migration-tool 2.1 exists as magento/data-migration-tool[2.0.0, 2.0.2, 2.0.5, 2.0.7] but these are rejected by your constraint.

Any ideas? There is an open issue on Github for this (https://github.com/magento/data-migration-tool/issues/104) but any help is appreciated.

Below is what I get when requiring data-migration-tool:2.0.7

  Problem 1
- Conclusion: don't install magento/data-migration-tool 2.0.7
- Conclusion: don't install magento/data-migration-tool 2.0.7
- Conclusion: don't install magento/data-migration-tool 2.0.7|remove magento/framework 100.1.0
- Conclusion: don't install magento/data-migration-tool 2.0.7|don't install magento/framework 100.1.0
- Conclusion: don't install magento/data-migration-tool 2.0.7|don't install magento/framework 100.1.0
- Installation request for magento/data-migration-tool 2.0.7 -> satisfiable by magento/data-migration-tool[2.0.7].
- magento/data-migration-tool 2.0.7 requires magento/framework ~100.0.0 -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9].
- Can only install one of: magento/framework[100.1.0, 100.0.2].
- Can only install one of: magento/framework[100.1.0, 100.0.3].
- Can only install one of: magento/framework[100.1.0, 100.0.4].
- Can only install one of: magento/framework[100.1.0, 100.0.5].
- Can only install one of: magento/framework[100.1.0, 100.0.6].
- Can only install one of: magento/framework[100.1.0, 100.0.7].
- Can only install one of: magento/framework[100.1.0, 100.0.8].
- Can only install one of: magento/framework[100.1.0, 100.0.9].
- Can only install one of: magento/framework[100.1.0, 100.0.2].
- Can only install one of: magento/framework[100.1.0, 100.0.3].
- Can only install one of: magento/framework[100.1.0, 100.0.4].
- Can only install one of: magento/framework[100.1.0, 100.0.5].
- Can only install one of: magento/framework[100.1.0, 100.0.6].
- Can only install one of: magento/framework[100.1.0, 100.0.7].
- Can only install one of: magento/framework[100.1.0, 100.0.8].
- Can only install one of: magento/framework[100.1.0, 100.0.9].
- Installation request for magento/framework (locked at 100.1.0) -> satisfiable by magento/framework[100.1.0].
0

That's not an issue or a bug, you're requesting a version of that package that does not exist. Why don't you request the latest existing version:

composer require magento/data-migration-tool:2.0.7
  • I editing my question above with the error I get when using 2.0.7 – qrider Jun 30 '16 at 21:34
  • @qrider then it seems that 2.0.7 is not compatible with magento 2.1 so you'll have to wait until magento releases a new version or downgrade to 2.0.7 – Claudiu Creanga Jul 1 '16 at 8:31
0

It looks like the data migration tool for 2.1 has not been released yet and will be out in roughly 2 weeks.

https://github.com/magento/magento2/issues/5244

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.