1

I have applied patch 6788 to magento EE 1.13 and also added block to white list but blocks are not displaying on home page

enter image description here

Please help

  • Check your site logs. If issue is related to Patch, there should be an entry in there. – Prateek Jun 30 '16 at 11:24
  • @Prateek no any error in log – Ranjit Shinde Jun 30 '16 at 11:38
  • If it's not a live site, try enabling developer mode. If it's a live site, you can enable it with IP conditioning. That should give you the reason for why you are not seeing your block. – Prateek Jun 30 '16 at 11:41
1

Thank you so much all of you for your time, my problem was with magestore bannerslider module. after digging into this I found the solution on this url

https://magentary.com/kb/magestore-bannerslider-broken-after-supee-6788-or-magento-upgrade/

error was :

SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘.value) = ‘0’) AND (start_time

To solve SQL error change line 60 in app/code/community/Magestore/Bannerslider/Model/Mysql4/Banner/Collection.php as shown in the diff below:

--- Bannerslider/Model/Mysql4/Banner/Collection.php
+++ Bannerslider/Model/Mysql4/Banner/Collection.php
@@ -59,3 +59,3 @@
             }
-            return parent::addFieldToFilter("IF($field.value IS NULL, main_table.$field, $field.value)", $condition);
+           $this->getSelect()->where("IF($field.value IS NULL, main_table.$field, $field.value) = 0");
         }

Make sure that bannerslider/default block is whitelisted at CMS > Pages or CMS > Static Blocks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.