1

I have magento 1.8.1.0, when adding products the images are uploaded in the admin panel but can't be seen in front view of shop. Have checked the images are stored in media/catalog/product/ folder. Have refreshed the cache and checked, removed the .htaccess file in media folder, checked folder permission is set to 777. Please help.

5
  • Have you tried to reindex. Because magento follows EAV structure to save data in database. Also check whether images are shown in admin panel by right clicking and open image in new tab option? Commented Jun 30, 2016 at 8:52
  • Yes, i have done reindexing, still no images and I right click on image and i'm able to view them Commented Jun 30, 2016 at 9:52
  • You said that the folder permission is right. Did you check the file permission as well? It should be 644... Commented Jun 30, 2016 at 17:57
  • so media,catalog,product... all these folders need to have 777 permission and image file 644? Commented Jun 30, 2016 at 18:26
  • did change the file permissions to 644, still no luck :( Commented Jun 30, 2016 at 18:38

3 Answers 3

1

It turned out to be the theme's issue, when i switched the store view to default theme, I was able to see the product images. I have contacted the theme author for the fix.

0

Check 1) Make sure that you have selected one of the image as Base, thumbnail and small image, in the Backend under Images.

enter image description here

Check 2) If still issue, try in your catalog/product/view.phtml

var_dump($this->getProduct());

and see if you are getting image urls in the dump?

7
  • yes i have selected as shown but still no product images Commented Jun 30, 2016 at 11:37
  • try the check 2 in the edit and try to debug the issue
    – Ajay Bisht
    Commented Jun 30, 2016 at 11:44
  • I got this when did the check 2 step - ["image"]=> string(21) "/a/t/aten-kn2140v.jpg" ["small_image"]=> string(21) "/a/t/aten-kn2140v.jpg" ["thumbnail"]=> string(21) "/a/t/aten-kn2140v.jpg" ["url_key"]=> string(68) "aten-kn2140v-40-port-kvm-over-ip-switch-1-local-2-remote-user-access" ["url_path"]=> string(73) "aten-kn2140v-40-port-kvm-over-ip-switch-1-local-2-remote-user-access.html" Commented Jun 30, 2016 at 12:46
  • do you see your image files in that path? they should be in that path under media/catalog/product folder
    – Ajay Bisht
    Commented Jun 30, 2016 at 12:53
  • yes they are present in media/catalog/product/a/t/aten-kn2140v.jpg Commented Jun 30, 2016 at 12:54
0

I increased the php_value memory_limit in .htaccess file to 512M, and currently i'm able to see images in category view page but see placeholder images on product view.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.