0

I was having an issue with the urls on the frontend with numbers like "-1" appending to the end of my product's url keys. I completely cleared out the core_url_rewrites and reindexed however now the full system url is appearing. I'm not sure how I can now get back my custom product urls. Is there another step to this that I am missing? I believe my settings in configuration->catalog->search engine optimization are correctly set.

Use Categories Path for Product URLs = no

Create Permanent Redirect for URLs if URL Key Changed = yes

Any help to get my urls to appear like example.com/product-url or example.com/catagory/product-url would be awesome. Thank you!

2
  • What do you mean by full system url? Jun 29, 2016 at 5:56
  • So you see catalog/product/view/id/xxx URLs everywhere? Did you clear the cache after a full reindex? Jun 29, 2016 at 7:50

1 Answer 1

0

sorry for the late reply. Thanks so much for writing on here. Also sorry for my poor term usage. By system url, I meant the url was appearing like catalog/product/view/id/xxx

The issue that I was having is that the site was not indexing the urls after I cleared the core_url_rewrite. To fix this, all I had to do was go into system->index management select Catalog URL Rewrites and click "reindex data".

For some reason when I selected all and chose "reindex data" from the drop down menu, the urls would not populate after clicking submit. Maybe the system just needed time to reindex the urls for categories.

In any case, I was able to resolve the issue. Thank you for your responses.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.