0

I have a multi site store set up as follows:

Website1 (base) - Store1 - View1 (default)

Website2 - Store2 - View2

Each website has it's own domain (ie store.co.uk for Website1 and store.com for Website2). My problem is that that checking out on Website2 redirects to the url for Website1 (store.co.uk/checkout/onepage/) which is not what I expected - we want the domain to remain store.com.

I'm not aware of any redirect rules in .htaccess that would cause this. Are there any admin settings that govern which checkout is to be used?

As this is the first multidomain store I've configured any advice given would be gratefully received.

Magento CE 1.9.2.4

It's worth pointing out that the contacts page for both stores has a secure url too and isn't redirected like checkout.

  • Other pages are working fine right?? – Asish Hira Jun 29 '16 at 6:14
  • Yes Asish, everything is working as expected until I hit checkout – gpcola Jun 29 '16 at 6:54
  • are you using any other checkout??? – Asish Hira Jun 29 '16 at 7:30
  • We're using the standard CE One Step Checkout. As it happens having completely cleared all caches again, including, this time, 'Cache Storage', and restarted apache the problem appears to have changed subtly. Now when clicking 'checkout' I am being taken to the shopping cart page rather than the checkout, but still on Website1's 'default' domain rather than the Website2 domain as expected. – gpcola Jun 29 '16 at 9:41
  • cookie problem. Please add right info on admin panel cookie management section – Asish Hira Jun 29 '16 at 10:06
0

Check your secure URL is correct for the faulty store/website. Checkout will often switch to SSL so looks up a different base URL to the unsecure site.

  • Thanks for the reply Robbie but both base and secure urls are correct for both stores. – gpcola Jun 29 '16 at 6:53
  • 1
    It's worth pointing out that the contacts page for both stores is a secure url too and isn't redirected like checkout. – gpcola Jun 29 '16 at 7:01
0

In the end this turned out to be an issue with configuration of the full page caching plugin I was using - Lesti FPC. Once the plugin was correctly configured the issue disappeared.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.