1

Can't access backend nor frontend after upgrade... That's what i can see:

Magento supports PHP 5.6, 7.0.2, and 7.0.6 or later. Please read Magento System Requirements.

Got it already running with PHP 7.0.6

Tried:

php bin/magento setup:upgrade 

Which gives me:

[Magento\Framework\Exception\LocalizedException]  
Area code is already set 
  • Can you find any errors/messages related to this in magento logs, apache/nginx logs, acces logs etc.? Is developer mode turned on? You should look for something to get a clue what's going wrong. – Akif Jun 28 '16 at 12:42
  • developer mode is active, no system /exception logs at all. just that exception that i've mentioned in command line. – Thomas Lindner Jun 28 '16 at 19:20
  • Can you explain what the state of the system was? Live/test site, with or without data, maybe sample data, any extension installed etc.? – Akif Jun 28 '16 at 19:53
  • it's a local system with product data (not sample data) and 2 custom extensions i've built. – Thomas Lindner Jun 29 '16 at 13:26
  • Just made a fresh install which is working now. Will have to redo everything i've done so far, but as long as it works again.... Thanks for your time and help @AkifGumussu – Thomas Lindner Jun 29 '16 at 19:13
1

On magento community they have mentioned that, Do not install or upgrade to a Release Candidate on a production system. Upgrade to a Release Candidate on a development system only.

Also it is advisable to go for fresh installation rather then upgradation for older one for magento ce 2.1 because they have made so many changes and which are not all compatible with older one. You can also refer link @ http://devdocs.magento.com/guides/v2.1/release-notes/ReleaseNotes2.1.0CE.html

  • I didn't update to a Release Candidate and it's not production system at all. – Thomas Lindner Jun 28 '16 at 19:35
  • Thanks for the advice, i made a fresh install now and it's working. Just have to re-add everything i've done so far. Thanks for your time! – Thomas Lindner Jun 29 '16 at 19:11
1

You don't mention what version of PHP you are using, however note that support for PHP 5.5 has been dropped in Magento 2.1 and the supported versions of PHP 7 have been changed to only support PHP 7.0.6 up to 7.1

See: http://devdocs.magento.com/guides/v2.1/install-gde/system-requirements.html

  • Sorry, i've added the info, i'm using php 7.0.6.... thought it would be clear that it worked already under 2.0.7. Got a lot of issues after the latest upgrade. Seems like it's an broken upgrade again... – Thomas Lindner Jun 27 '16 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.