2

This error shows up everytime I click on a product. The product loads and saves properly. It began to appear before I updated to 2.1 and still continues to appear after the update.

error http://ttothefourth.com/errorimg/error.png

This is what I got from Chrome Inspect: error http://ttothefourth.com/errorimg/error1.png When I clicked the link:

1 exception(s):

Exception #0 (Magento\Framework\Exception\LocalizedException): Object DOMDocument should be created. error http://ttothefourth.com/errorimg/error2.png


This was in var/report

a:4:{i:0;s:37:"Object DOMDocument should be created.";i:1;s:5384:"#0 /home/ttothef1/public_html/vendor/magento/framework/View/Element/UiComponent/Config/Reader.php(95): Magento\Framework\View\Element\UiComponent\Config\DomMerger->getDom()

error http://ttothefourth.com/errorimg/error3.png

2

If you have the "review" module disabled.

Enable it, only fix for now.

|improve this answer|||||
1

I think it should be enough if you delete the var folder, delete pub/static/adminhtml and then run php bin/magento setup:di:compile and php bin/magento setup:static-content:deploy

|improve this answer|||||
0

Run this command on your terminal to enable all modules and to do the deploy again:

alias mage="php -d memory_limit=-1 -f bin/magento"

chmod -R 775 pub/static/ var/ pub/media/ &&
rm -rf var/view_preprocessed/ var/cache/ var/page_cache/ var/tmp/ var/generation/ pub/static/frontend/ ;

mage module:enable --all

mage cache:clean &
mage cache:flush &
mage indexer:reindex &
mage setup:upgrade &&
mage setup:static-content:deploy ; mage setup:static-content:deploy -f;
mage setup:db-data:upgrade &&
mage dev:source-theme:deploy &&
chmod -R 775 pub/static/ pub/media/ var/
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.