0

I'm trying to install Magento on my VPS (WHM/cPanel) but I get the following error. I've checked the memory and increased it to 512M but still no luck.

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 248 bytes) in /home/exampleuser/public_html/vendor/magento/module-sales-rule/Model/ResourceModel/Report/Rule/Updatedat.php on line 36

Things I've tried:

  • Developer Mode
  • Check .htaccess file
  • Changed the php.ini in the root to have more memory
  • Changed php.ini of the server also ..

I've never had issues with memory before, the Magento system requirements are met.

5
  • How are you trying to install? Which platform?
    – MagePsycho
    Jun 24, 2016 at 13:00
  • via GUI, tried the command line and its the same.. No extra info is given, I have enabled logging and tried it in developer mode. Why has my post have a -1 next to it?
    – Zak Lewis
    Jun 24, 2016 at 13:01
  • Try via command line using: php -d memory_limit=-1 bin/magento [command]
    – MagePsycho
    Jun 24, 2016 at 13:11
  • Who is the host?
    – Ryan Hoerr
    Jun 24, 2016 at 14:11
  • @MagePsycho That didn't do anything. It's hosted on TransIP with a WHM/cPanel setup.
    – Zak Lewis
    Jun 24, 2016 at 21:34

1 Answer 1

3

Your error indicates the memory limit is 32 MB (very low). Given the ways you've already tried to override it (including through cPanel), I would recommend contacting your host about the problem.

You might also see if your host has any kind of FAQ for dealing with PHP setting changes; sometimes there are special arrangements.

1
  • You were correct, I did a find for memory_limit and found another php.ini file. Thank you for the help!
    – Zak Lewis
    Jun 24, 2016 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.