4

I got a problem with Magento translation in my translate.csv, because it does not work. It should be easy as all tutorials saying.

I had download the package/module translation put into \app\locale\xx_XX folder and create own translate.csv file in *

\app\design\frontend\[theme]\default\locale\xx_XX

folder.

Some word get the translation was giving priority to the module .csv not to my translate.csv. I cleared all cache files but to no avail.

For instance:

module Mage_Customer.csv: “Fax”,"Faks"
translate.csv: “Fax”,"Fax"

Problem: In the customer account page, it always displayed “Faks” instead of “Fax” which is not I expected.

Did I miss out something? Fyi, im using magento vers 1.7.0.2 CE.

Thank you in advance.

11

I found this old topic, and later found a solution: when the same string exists in multiple module translation files, then Magento will scope it, by default with '::'. So you also have to create separate translation strings for all those scopes in your translation.csv

"Mage_Customer::Fax","Fax"
"Mage_Checkout::Fax","Fax"

And for all the other modules in which "Fax" appears (and you care to translate differently).

  • exactly what solved the problem! – Ria Weyprecht Mar 10 '15 at 9:13
1

Please Make Sure You display Value at account page using

<?php echo $this->__("Fax"); ?>

if you write in above code then It will definitely translate.

  • I did not touched the core code. That part of code you mentioned was there under \app\design\frontend\base\default\template\customer\address\edit.phtml (line 64). I got to know this file after enabled the path hints. – Leongelis Dec 23 '13 at 9:59
  • In Translate.csv you write wrong code. try translate.csv: 'Fax','Fax' – Keyul Shah Dec 23 '13 at 10:14
  • I have tried for "Fax","Fax" and 'Fax','Fax' but still no luck. – Leongelis Dec 23 '13 at 10:29
  • make sure that you are changed in proper file because suppose you are changing in fr_Fr and you write in code en_EN translate.csv. – Keyul Shah Dec 23 '13 at 11:08
  • Sorry, just off from office. Some words are working fine with this translate.csv. This file saved under app\design\frontend[theme][sub-theme]\locale\id_ID\ – Leongelis Dec 23 '13 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.